不去在乎结果,热情地付出过,就好了.

CategoryAndroid

CentOS编译小飞机R(粉色界面改颜色)

C

应小伙伴要求给小飞机R改个颜色,从来没搞过,撸起袖子干。 主机为Win10,使用自带的Hyper-V虚拟机,建立二带虚拟机据说性能好一些,关闭安全启动不然无法从ISO文件启动,虚拟机中最小安装,安装CentOS-7-x86_64-Minimal-1611,CentOS具体安装步骤不详细说明,因为我是最小安装,你们照我这篇来搞应该不会缺失什么库之类的,装完更新一下系统: 安装jdk 1.8.0: 配置java环境变量,在/etc/profile 尾部追加: 应用环境变量: 然后运行一下java和javac看看有输出不报错就可以了,自己新建一个目录,把小飞机R源码从github上拖下来: 拖下来之后进到目录里面下载一下依赖库: 下载如果出错则虚拟机需要出墙,再把ssr客户端的源码拖下来: git clone 小飞机R/小飞机R.git 配置什么的不说了,见这里:[更多内容]

配置Genymontion虚拟机,VirtualBox和Hyper-V共存

官方SDK里面的AVD虚拟机效率不行,运行起来太慢,网上看到Genymontion模拟器貌似不错。 是可以免费使用的,点击Buy,拉到最下面小字免费下载(点此直接到达)。 然后趁下载的空注册个账号,不注册不能配置虚拟机(点此直接到达)。 安装好点ADD添加虚拟机,选完型号之后需要下载一些文件,大概一二百兆,这个时候如果不出意外会报下图的错,这是中国网络的问题,不能说得太细,在下图配置一下就好了,请自行解决,然后就可以正常下载了。 报错内容: Unable to create virtual device. Server returned HTTP status code 0    建好虚拟机先运行一下看看,报错了,可以看出用的是VirtualBox,让我到VB里面去运行一下。打开VB,点启动,看下错误,提示VT[更多内容]

minSdkVersion、maxSdkVersion、targetSdkVersion、target的区别

m

在AndroidManifest.xml中: minSdkVersion: 即在建立项目时的MiniMum Required SDK,系统API低于该属性声明的API等级,则应用不能安装。因为高API等级的系统可以运行低API等级的应用,反之却不行,所以此属性的值应该是应用中所使用的所有API接口中的最高等级。 maxSdkVersion: 高于该属性声明的API等级,则应用不能安装,一般不设置。 targetSdkVersion: 即在建立项目时的Target SDK,告知系统此应用是以该属性声明的API等级为目标编译的,系统可以不进行兼容性检查。该属性只起到告知的作用,实际的兼容性问题需要开发者自己处理。 在project.properties中: target: 即在建立项目时的Compile[更多内容]

Eclipse不显示Console

E

真是太小白了,瞎整整的Console都没了,上网找了一下,记在这里。
三个方法:
1,手动打开Console窗口:
Windows > Show View > Console 或者快捷键 Alt+Shift+Q,右下弹出提示后按C,如图:

2,设置 Console显示的时间:
Windows > Preference > Run/Debug > Console,勾选两个Show,如果已经勾选了,就去掉在勾上,如图:
 
3,切换到要查看的Console:
如果已经显示Console窗口了,但是没有期望的内容,可能是切换的窗口不对,点击Console窗口右边的控件切换,如图:

发现了以元素 ‘d:skin’ 开头的无效内容。此处不应含有子元素。

Eclipse+ADT的开发平台在建了Android 5.1(API 22)和6.0(API 23)的虚拟设备后每次打开Eclipse会报错:
发现了以元素 ‘d:skin’ 开头的无效内容。此处不应含有子元素。
解决方法有二:

用 ./sdk/tools/lib/devices.xml 替换报错路径里面的对应文件。
还有一个歪法,在SDK Manager里面把Android Wear的image删了。

不去在乎结果,热情地付出过,就好了.
某一天,你所坚持的,和承担过的一切,会有回应。它们并非失去踪迹,只是需要时间抵达。这和星光落入眼睛里,是一样的道理。

近期文章

近期评论