跳到内容

最新文章

安装IIS提示无法复制convlog.exe,iisadmin.mfl等文件的处理

IIS出了点问题,就重新安装.

于是在安装IIS时如果老提示无法复制convlog.exe、iisadmin.mfl等文件.

在网上搜一堆,说是因为损坏了系统内部数据库所致.修复损坏的数据文件即可正常安装.

解决方法如下(开始>运行>输入CMD>再输入以下命令):

esentutl /g %windir%/security/database/secedit.sdb

(该命令参数用于查询secedit.sdb文件是否被损坏)

esentutl /p %windir%/security/database/secedit.sdb

(修复secedit.sdb文件)

这样convlog.exe是可以安装了,但到了iisadmin.mfl无法找到.

点浏览,C:\WINDOWS\ServicePackFiles\i386,导航到这个文件夹下,再点确定,就可以安装了.

捷安特软尾系列

Anthem 3.5” XC

Anthem X 4.0” XC

Trance 4.2” trail

Trance X 5.0” trail

Reign 6.0” AM

Reign X 6.7” AM

Faith 7.0” FR

Glory 8.0” DH

Linux安装字体

1,先从你本机 C:\Windows\Fonts 拷贝或者网络上下载你想要安装的字体文件(*.ttf文件),

到/usr/share/fonts/chinese/TrueType目录下(如果系统中没有此目录,则自行mkdir创建,亦可重命名为自己喜欢的文件夹名)

2,修改字体文件的权限,使root用户以外的用户也可以使用

# cd /usr/share/fonts/chinese/TrueType
# chmod 755 *.ttf

3,建立字体缓存

# mkfontscale

(如果提示 mkfontscale: command not found,需自行安装 # yum install mkfontscale)

# mkfontdir
# fc-cache -fv

(如果提示 fc-cache: command not found,则需要安装# yum install fontconfig)

CentOS 解决找不到解码器 安装视频解码器

第一步,下载与操作系统相配的RPM包,用uname -i可以看到操作系统类型,i386下载第一个,x86-64下载第二个:

i686

http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm

x86_64

http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

 

第二步,安装 DAG的GPG密钥,用于验证RPM完整性:

rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt

 

第三步,校验RPM包完整性

i686

rpm -K rpmforge-release-0.5.2-2.el6.rf.i686.rpm

x86_64

rpm -K rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

 

第四步,安装RPMForge软件包,这个包大约12KB多,只是rpmforge的工具

i686

rpm -i rpmforge-release-0.5.2-2.el6.rf.i686.rpm

x86_64

rpm -i rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

 

检查软件包更新情况(可不必做),

yum check-update

如果显示类似信息是正常的:29 packages excluded due to repository priority protections

 

这个时候其他的就不用做了,网上给了很多,装各种软件,

其实这时候原装播放器已经可以搜到解码器并安装了.

Linux下为Firefox和Chrome添加Flash支持

刚安装的系统没有Flash插件,想在线听个歌都不行,

搞了几天都没整出来,

一个偶然的机会,我在Firefox里面点了下面的链接:

“附加组件”>”插件”>”看看您的插件是否都是最新的“,

提示是Flash版本过旧已被禁用,

我一直以为没有Flash插件的,原来是太旧了,

根据提示,到这里下载最新版本:

下载 Adobe Flash Player,

这个链接我之前是进过的,但是懒省事,下载的是YUM版本,

装完以后没反应,又不知道装哪了,就做罢了,

这次我下的.tar.gz压缩包版本,自己动手吧.

在终端进入能看压缩文件的那层目录,

执行下面的命令解压:

tar -zxvf install_flash_player_11_linux.i386.tar.gz 

解压完了里面是有说明的,我还是再讲一下比较清楚.

解压完有一个libflashplayer.so文件和usr文件夹,

在终端进入能看到这两个文件的那层目录,执行下面的命令:

sudo cp -r usr/* /usr

接着是Firefox的设置:

接上面,执行下面的命令:

cp libflashlayer.so ~/.mozilla/plugins/

重启Firefox即可.

接着是Chrome的设置:

基本Linux系统都是内置Firefox,所以一般都会做完上面的设置,

这是其实Chrome已经自动可以调用~/.mozilla/plugins/libflashlayer.so了,

如果您没有设置Firefox,请参照下面的设置,

接Firefox上面,执行下面的命令:

sudo cp libflashplayer.so /opt/google/chrome/plugins/

这样已经为Chrome添加了Flash插件(不是扩展哦),

但是现在还不能使用呢,

原因就是Chrome其实内置了libpepflashlayer.so(不是libflashlayer.so),

但是同一个功能的插件有两个,会先调用内置的,所以就有了上面的问题,

至于内置的不能使用的原因,感兴趣的自己搜索吧,

解决方法就是禁用内置Flash插件,操作如下:

在地址栏输入chrome://plugins/,

建议不显示详细信息,这是应该有:

Adobe Flash Player – 版本: 11.2 r202 和 libpepflashplayer,

点击libpepflashplayer下面的停用,把它禁掉,

重启Chrome就行了,

OVER.

PS:我喜欢一进终端直接su,

搞得现在家目录下面一堆在X界面不能操作的东西,烦人,

所以建议大家尽量使用sudo,

或者能不使用超级权限就不要使用.